SFDC sync error: "couldn't connect to host"

Issue

You encounter a "Couldn't connect to host" SFDC sync error.

Environment

Salesforce

Solution

This is a message returned by Salesforce to Marketo indicating that for some time, Salesforce couldn't be accessed because the SFDC servers were temporarily down. This could be caused by transient SFDC Server issues/outages but is most commonly caused due to scheduled Salesforce database maintenance.

When these errors occur, Marketo will continue to sync to SFDC where it last left off once the Salesforce servers are back up and running - however, this only applies to records already syncing with SFDC.

If any records affected by this sync error were attempting to initially sync (through "Sync person to SFDC" flow steps, for example), then the flow steps need to be run again to push any of those records to SFDC for the first time. The global background sync works on its own and will automatically retry to sync any recently updated records (that were already previously syncing with SFDC) after the Salesforce server outage has been resolved.

Root Cause

Server outage or scheduled maintenance on SFDC servers